Back to overview
Downtime

Some services are down

May 27, 2022 at 03:01am UTC
Affected services
Global API Service
rapidstorapp.com
rapidstorapp.com.au

Resolved
May 27, 2022 at 04:57am UTC

Services are back online and operational. We will continue to monitor over the next few hours to confirm full operational status

Updated
May 27, 2022 at 03:58am UTC

RapidStor is now operational again, but there may still be intermittent performance issues while we scale the servers back up to full capacity.

Created
May 27, 2022 at 03:01am UTC

RapidStor Services are currently unavailable. We are currently working to restore functionality as soon as possible.