Get in touch
Back
Resolved

RapidStor Payments currently not working

Started 26 Aug at 09:32pm AEST.

Created

There is an issue with RapidStor payments failing. The team are investigating. This is linked to the SCA update issue yesterday.

Posted 26 Aug at 09:32pm AEST.